让wordpress的版本和插件支持自动更新

发现周围用WP的很多都不知道它本身就是支持自动更新的,不需要手动上传那么麻烦。这个也归咎于wp在安装时应该引导用户设置正确的文件夹权限,wp要自我更新必须要有更改自己文件夹的权限,也可能因为这个权限比较高,为了规避风险没有提示用户这么干,但咱是懒人,没有更新到新版的wp可能本身就是一个大的风险。

https://wordpress.org/support/topic/folder-permission-on-linux-ubuntu

如果你很懒,可以把整个网站设置为www-data

比如:chown -R www-data:www-data /yourwebsite

如果只是想支持插件更新,也可以只修改wp-content的权限

比如:chown -R www-data:www-data /yourwebsite/wp-content